Huge icons in 1.99.11, Fedora 29 and 30

I have been using the version on the Fedora repo (1.99.8) for a couple of weeks, I upgraded manually to 1.99.11, by downloading the appropriate RPM from the site. Now the icons on the top bars look huge. Has anyone else experienced this and knows a workaround?

I was on Fedora 29, upgraded, now am on Fedora 30, it happened in both.

Thanks

For TeXmacs 1.99.11 (with latest code)

Solution 1

Check the View -> Retina Settings... menu,and toggle Use retina icon option.

Solution 2

Using the following code snippet:

(set-retina-icons 1)
1 Like

Click View in the menu, there is an item called High resolution screen, do the following:

  1. uncheck everything; if you did not uncheck these options, you will notice a differece when you select some texts when editing. At least, I have this experience on Windows and ArchLinux.
  2. Change the Graphical interface font scale to 1.
1 Like

Thank you both! I don’t know how I missed those settings.