Beamer is very laggy

Here’s the file I am working on.

Also, note that I’m on arch linux.

1 Like

Many thanks for sharing. I still get a decent speed. You could check what timings you get by enabling Tools->Debugging tools, then Debug->bench. If you run TeXmacs from the terminal this way, it then prints the time it takes to typeset after every keystroke. I get either 0 ms or 1 ms.

I am on Fedora, but I believe the AppImages should have all dependent libraries built in, so the distro shouldn’t make much of a difference.

I also get 1 ms and 0 ms. In my case, about 90% of the time, it’s 1 ms. I also observe the occasional 2 ms.

I hope you don’t mind me asking you an unrelated question. Is it possible to automatically run all pygment blocks? I have made some changes to the syntax file and I don’t want to rerun each pygment block manually.

Not that I know of, but it should be possible with a few lines of Scheme. The Scheme command for switching between folded and unfolded trees is (alternate-toggle t) where t is a tree (to test it, go to Debug->Execute->Execute scheme expression and enter (alternate-toggle (cursor-tree)) while the cursor is inside a fold). Combined with a filter to find all executable folds, it should be possible to do what you want.

Hello, I tried installing the dev packages under linux under WSL and I do not see any particular issue. My response time is around 0-2ms in the bench. It seems a bit snappier than what you recorded (btw, the gif is probably low framerate itself so it is difficult to appreciate the slowdown)

While typing the CPU does tend to baloon a lot but it slows down as soon as you stop. I get around 30%-40% utilization while holding down a key (however, this is not really telling since it is running under WSL).

Let me know if I can help in any other way

1 Like

I am using linux, not WSL. Also, the video you see is not a gif and I made sure I recorded at 60fps. As I also mentioned, the issue doesn’t exist in older versions.

I deeply and sincerely apologize if my contribution seemed dismissive. That was by no means my intention. I was not trying to invalidate your report. I was just contributing another data point. Based on this example it seems that the issue might be related to the incompatibility of the current snapshot with some specific system configurations.

The video
You are right, sorry about the misunderstanding: my bad

The version
I did use the snapshot version, not the old one; as per your specifications. I have currently no means to test the AppImage.

The check I reported is using the new version that you linked from the OpenSuse Build Service so I believe we are talking about the same version. Actually, I tested it both on the old vesion I had installed, and then I de-installed it and installed the snapshot you linked to. I could not detect an appreciable difference.

The system

WSL is Linux in a sense. It runs Linux binaries and uses native Linux libraries. WSL is essentially a virtual machine of sorts. I run the Debian, so I installed the Debian package that I downloaded from OBS.

More testing

I am actually planning on having several virtual machines with different configurations ready so that at least I can help testing. Not having a dedicated computer, I will set them up insider a true virtual machine, not WSL (side note: WSL is still useful because it seems to be the only reasonable way to run the guile3 port). I will try to get an Archlinux system running as soon as I have some time.

My experience with slugginess

A similar slugginess you encounter, I encounter it sometimes using the current Release version (not the snapshot) under Windows. However, this may be due to a completely different issue.

I sometimes manage to solved it temporarily by restarting TeXmacs and sometimes by clearing the $HOME\.TeXmacs directory. Removing $HOME\.TeXmacs\system\*.scm and $HOME\.TeXmacs\progs\*.scm has usually no bearing on this so you can avoid removing them and not lose your settings. I think the cache might be the culprit.

Since @jeroen cannot reproduce the issue, did you try clearing the cache?


No need to apologize; I was simply trying to eliminate obvious causes for the effect I was observing.

How do you clear the cache? I only see an option to clear the font cache.

1 Like

There are a few (undocumented) command line switches for clearing caches. To delete most caches, try to run texmacs -delete-cache.

Another way to debug this would be to run with a temporary new TEXMACS_HOME_DIR. This can be done like this

TEXMACS_HOME_DIR=~/.TeXmacs.temp texmacs

This will set up a clean config directory under .TeXmacs.temp and run TeXmacs.

If after your debugging you run plain texmacs again, you will be using your normal config dir again (.TeXmacs).

1 Like

Unfortunately, that didn’t help.

Here is a video that compares the new version with the old version:

1 Like

These scheme commands should toggle all script switches between input and output (use with Debug->Execute->Evaluate scheme expression):

(map alternate-toggle (select (buffer-tree) '(:* script-input)))


(map alternate-toggle (select (buffer-tree) '(:* script-output)))
1 Like

Also Archlinux here, with AMD 5600U, linux 5.19.6.arch1-1 and aur/texmacs 2.1.2-1. Your doc behaves smoothly on my computer.

1 Like

Thanks! @hamorabi maybe I missed it but there are other situations in which you experience slowing down? Have you tried on other computers to see if the problem is also present?

I have tried the debian package inside a docker container and it didn’t seem to have any sluggishness. My main system runs Arch. All versions of Texmacs 2.1.2 (appimage, native binary) are sluggish on my Arch. At the moment, I am using an old appimage. That one runs fast, but has the blurry image problem for which I had already created a thread. So, at the moment, I am making a choice between sluggish but displays crisp images vs fast but blurry images.

Please, re-check the other thread: you reported then the old AppImage was crisp, the opposite of today. You see, mixing threads confuses even you :laughing:

Like the others reporting here, I have not seen marked differences in responsiveness between 2.1.1 and 2.1.2. . Your bench debug shows ms times similar to other users, so no huge anomaly there, as far as we can tell. In your videos, you use keyboard autorepeat and you also change the framerate. That’s not representative of real typing, and that being more or less choppy does not worry me overly. When using TeXmacs, I’m the bottleneck in the input process, not the program.

Unfortunately I have now a new Apple machine which makes me difficult to track down this problem. The file you shared do not have the images, and I can imagine that they could generate this kind of issues (but I’m not sure). I can suggest that you share a problematic document including all images (instead of linking the images, TeXmacs can directly include them in the document, just select the green arrow in the focus bar when focussing on the image). This will make possible to other users to reproduce your setup. Given that you do not experience the problem in other installations I guess there is some interference with the arch distribution.

Let me also say that there are indeed some situations which make TeXmacs laggy. This depends mostly on some constructs in the document, not on a general inefficiency of the program, and it would be useful to understand the precise conditions of these problems. In general TeXmacs is very responsive even with very long documents. Tables and images or drawings could however cause these delays since are more time consuming to process during typesetting. If we can track down some relevant cases we would be able to optimise them away.

I noticed a similar issue which may be related. In one of my document, I type everything in one slide and use the papyrus page mode in teaching. If I change the view to paper mode, then typing becomes very laggy. However, there is no such issue in another document.

1 Like

I do experience observable sluggishness in your builds of TeXmacs 2.1.2 on Debian Bullseye, which cannot be reproduced in either TeXmacs 2.1.1 (official build), or Mogan, on the same platform. Furthermore, it does not seem to be reproducible for the official build of TeXmacs 2.1.2 on Ubuntu as well.

The sluggishness in question is global, and particularly significant when the first math formula is typed.