Broken shortcut for sections

Since the release of TeXmacs 1.99.14 under Windows, it appeared that special Alt Codes are now supported but it added a problem : the shortcuts that are used to create new sections are now broken. The shortcut for a section is Alt+1 but instead it gives the emoji :slight_smile: and I think it goes the same for every other shortcut including Alt+Code.
Does anyone have an idea how to go back to the old way of working, without going back to TeXmacs 1.99.13? Or if it is a know issue?

These shortcuts work the same way for me in 1.99.15 and 1.99.12 on Linux. Both create sections. What do you mean by “the old way of working”?

This is probably Windows intercepting the shortcut and inserting the emoji, so TeXmacs is only displaying what it sees as input.

You could create your own shortcuts by putting a kbd-map command in $TEXMACS_HOME_PATH/progs/my-init-texmacs.scm
E.g. I have the following in there to easily import LaTeX snippets from the clipboard (Ctrl-F5) and to export to PDF (Ctrl-F6).

("C-F5" (clipboard-paste-import "latex" "primary"))
("C-F6" (choose-file wrapped-print-to-file "Save pdf file" "pdf"))

What I mean by “the old way of working” is that this problem doesn’t show up for versions strictly under 1.99.14. I tried reinstalling TeXmacs version 1.99.13 and I could use the shortcuts just has they would on your Linux machine.
This : Alt Code (Wikipedia), seems to be what is causing me trouble as this kind of shortcut it wasn’t working the Microsoft way before but now with the newer version of TeXmacs, it is! I’m a little embarassed as it was saving some time to be able to write quickly.
Thank you for the method. I will try it but I am not an expert so it will be a little difficult for me to implement it.

Even with the new version 1.99.15, we have an emoticon when we do Alt+1 instead of having a Section. Certainly a bug.
Windows 10.

Judging from the git repository there have been some changes to the processing of key presses since 1.99.13. I can’t say I understand what’s going on, though.

As a workaround, you could also use Markdown-like shortcuts “# # Tab”, “# # # Tab” and “# # # # Tab” to create sections, subsections and subsubsections respectively.

I would be good to file a bug report on savannah about it.

Could you please tell us what kind of keyboard you are using?
Also, when you say that the same holds for every other shortcut including Alt+Code,
could you be more specific? Does this only concern the case when ‘Code’ is a digit,
or also other shortcuts?

I just tried with both a French and an English keyboard on a Windows 10 machine and
I could not reproduce the problem.

Could you please provide more info about your setup?