Cannot type "â" without a space

You can type Alt+i followed by a to have â. It works for me on a Mac. Maybe on another operating system you need to replace Alt with the correct modifier.

Maybe the problem occurs specifically with ^+a (in french keyboards)…

Update : the problem do not occur on Windows

For me neither. I did not make the keyboard shortcuts for accented letters work, so I changed keyboard layout to French.
Both in Windows and in Ubuntu I could type ^a to get a letter â, and no space appeared in front of the letter.

I changed the layout, and every french layout has this problem and it’s really pissing me off.
Maybe the problem comes from the fact that I installed the app from this repository (version 22.04 and I am on 22.10). But I tried appimage from this same repository and I still have the problem.
I cannot install from the officiel .deb repo or compile it because it creates too much problems.
Do you know another way to install the app for me, that may correct this problem, I really don’t know what to do and it is really bothering me because I use Texmacs for really everything.
Thanks in advance and sorry for the trouble.

Hi @JMTch, I will be able to help very little because I know very little about keyboard layouts and characters.
By the way I think that

this is a crucial issue for TeXmacs. I know that @mgubi worked quite a lot on finding a good substitute for Guile 1.8, and I understood that every candidate has a drawback that makes it unsuitable at least right now. I am hoping that there may be some breakthrough :slight_smile:

I have one small suggestion, that is to try and look at the log of the keyboard presses that TeXmacs sees, it is under Tools->Debug and then select Keyboard. Maybe it helps for finding out the cause of the malfunction. The log is sent to the terminal by default, so you need to start TeXmacs from the terminal; I assume (I did not try it) that it can be redirected to a file.

Hello, without redirecting to a file, the debugger only tells me that I typed this image.
I think i’s a misunderstood character or sth like that. How can I stop texmacs from trying to generate it.
When I am doing the same thing in “no style” version of a doc (which causes no problem) I have this : image
It’s the same thing, but I do not have the space problem.
So, I repeat, is there a way to stop this pre-edit thing ?
Thanks in advance I am losing hope currently hahaha

Sorry, I do not know enough to be able to help further.

If no-one else can help you, I think it is the case to submit a bug report at

I ended up by just changing â and ê to make it writted by altgr+a and altgr+e on my keyboard layout and now I just need to reaccustom myself.
I think I can say I solved it, not in a really satisfying way but it’s solved.
Thanks to all for your help

1 Like

Maybe this is also a hint to the cause of the wrong output.

A workaround that worked for me is to install an external input method and make sure TeXmacs uses it. For instance, you could apt install ibus, then launch ibus, and finally run TeXmacs with QT_IM_MODULE=ibus texmacs. (As a bonus, you can then install for speech input support.)


I’m making these builds, I’m French and I use my own dog food on linux (not KDE, though). Never had this issue. I just checked with the latest AppImage and less recent ones, and when I enter “lâche” with debug-keyboard on, I get:

TeXmacs] debug-keyboard, Pressed l at 18853
TeXmacs] debug-keyboard,   Codes 108
TeXmacs] debug-keyboard, l -> l -> l
TeXmacs] debug-keyboard, Pressed pre-edit:1:^ at 19654
TeXmacs] debug-keyboard,   Codes 112 114 101 45 101 100 105 116 58 49 58 94
TeXmacs] debug-keyboard, Pressed � at 21157
TeXmacs] debug-keyboard,   Codes 226
TeXmacs] debug-keyboard, � -> � -> �
TeXmacs] debug-keyboard, Pressed pre-edit: at 21157
TeXmacs] debug-keyboard,   Codes 112 114 101 45 101 100 105 116 58
TeXmacs] debug-keyboard, Pressed c at 21521
TeXmacs] debug-keyboard,   Codes 99
TeXmacs] debug-keyboard, c -> c -> c

and 226 is the unicode for the expected â (and it comes with no spurious space in front). I’m curious about the origin of the “Pressed speech” in your debug output.

Has this problem ever been present on your side, or did it start recently?

I’ve just tried in a KDE live session and the bug occurs with recent versions, but not with an AppImage dating back last April. It really looks like this bug was introduced along with speech input back in October. It occurs in KDE because, unlike on my desktop env., keypresses go through an Input Method before reaching TeXmacs:

TeXmacs] debug-qt, IM committing: â
TeXmacs] debug-qt, keypressed
TeXmacs] debug-qt, key  : 0
TeXmacs] debug-qt, text : speech:�
TeXmacs] debug-qt, count: 8
TeXmacs] debug-qt, unic : 115
TeXmacs] debug-qt, key press: speech:�
TeXmacs] debug-qt, IM preediting :
TeXmacs] debug-keyboard, Pressed speech:� at 3321524

Hello, I have a similar problem under ubuntu mate 22.04.
The problem arises with the circumflex accent but also the trema .
(see screenshot)
I have the latest version of texmacs find on the site :

I’ve initiated new builds in which I just reverted the change that broke entering accented characters in linux distros which use Input Methods. These new builds should soon become available on the download servers and they should solve the issue, until a proper fix is worked out in the trunk.



on a 24.04 ubuntu fresh installed texmacs (the deb from the official website), I encounter the same problem with circonflexe ^ and trema ¨ accents.

This is the first time I face this “bug”.

I downloaded the appimage from the official website which doesn’nt launch. I’ll create a new question for this problem.

Thank you


Just installed slowphil 23.10 version, and the problem remains : no ^ or ¨ accents.


Problem solved for the input. I just changed the keyboard layout and it works.


1 Like

The bug originally reported was fixed in r 14299 and should no longer affect latests builds. What is your distro, desktop environment, and what are the keyboard layouts involved (with and without the issue)?

Hi Philippe, Hi to all,

My distro is ubuntu 24.04 freshly installed
I tried all the packages (yours, the deb one from the website and the one from the repo)
The good keyboard is Français (variante, Latin-9 uniquement)
The one that caused problems : Français (obsolète, variante, sanss touche morte)

My PC is a HP EliteBook 830 G10