Editing of Revtex AIP Style not possible

Hi, I am trying to edit the Revtex AIP Style template but I see this

If I go to the Program folder I can see code but not from TeXmacs. I am on Windows 11.
Can anyone help me with a hint is this style possible to edit in TeXmacs?

It may be a bug.
It looks as if the program does not know that it is in Source Style, even if in the style on the bottom left of the ribbon I read “Source”.
Let us see if anyone has suggestions.

I just tested and that style file opens correctly on windows for me. Maybe you inadvertently made edits to the file in a text editor? Although *.tm or *.ts files are rather readable in text editors, spaces and newlines are meaningful and modifying them may corrupt the file structure; In short, *.tm or *.ts files are not supposed to be edited outside of TeXmacs. Try downloading the original file and see if it works better.

Thank you for your continual help. I just did that. I also cleared the cache by deleting the System folder at %appdata%/TeXmacs. Still, this issue is not solved. When I go to Edit Source I get this message:
Warning: Couldn’t concretize tuple (concat, etc, papersize)

Warning: Save error for C:\Users\Korisnik\AppData\Roaming\TeXmacs\system\cache_C\Program Files \TeXmacs_ _,No error
Like this:

and this is what I see .
It is funny that I can open the first three if I select them and then go to Preferences/edit source
but all below do not provide that option on select at all.

Maybe you are missing source.ts, whose default location is $TEXMACS_PATH/styles. Could you please check what happens if you open other .ts files?

I checked and the source file is present in the folder.
I also tried to open other ts files, I was promoted with warning messages

  • Warning: Couldn’t concretize tuple (concat, etc, papersize)
  • Warning: Save error for C:\Users\Korisnik\AppData\Roaming\TeXmacs\system\cache_ C \Program Files \TeXmacs_ _,No error
    but after I discarded them I could see the source. Than I unchecked the Default option in paper size options and warning messages disappeared for all .ts. files and all are editable except AIP.
    Now I can see this for all blocks on the AIP source page signals that the source can be opened, but each one opens the same source, when cliked, the same source three on the top opened.

I am using version 2.1.1 from TeXmacs website on Windows 11 Pro with all the latest updates.

Also, please notice on this image that there are two marks just bellow the Headers and Footers box

I did not edit the file, this file is the one you suggested to me to download today. Those marks were also visible on the old .ts file yesterday. I can not edit them, delete …

EDIT. I just have managed to delete them, but nothing changes

What happens if you try and assign the style “No style” to the document?

Something went wrong in your TeXmacs user folder; cleaning it might resolve the issue. Try quitting TeXmacs and then delete the folder C:\Users\Korisnik\AppData\Roaming\TeXmacs\system and then retry. If that is not enough, try removing C:\Users\Korisnik\AppData\Roaming\TeXmacs entirely.

Hi, I have tried to delete folders but problems persist. I am getting the same warnings also. Could the installation file be corrupted? Is there somewhere alternative installer?

I see all the <body> tags, but nothing changes in the access to the .ts file. For some reason unknown to me, the first page remains green. I believe I attempted to change it through the menu yesterday, but I didn’t realize it was successful. Color didn’t change.

I don’t understand which <body> tags you are referring to, neither what “green” means in

Could you please post an image of the aip.ts file with the “No style” style, setting as well (I did not say it in the previous message) the editing in Source mode (Document -> Source -> Edit source tree)?

Yes of course, this is what I see in source tree mode

Earlier, when I used the option no style image I got this view with the green color but I suppose it is because I was experimenting yesterday with this option in menu . It has not produced any change of page color until I have tried the ‘no style’ option today.

To be open, I was looking for a wey to customize the first page Header, that is why I opened source view and encounter this issue. Is there any other way I could cusomize the header on the first page? I haven’t find any way to do that via menus.

I don’t know how to do that, as I don’t know to detect the page number in a document. The environment variable page-nr is not available during typesetting (see manual). One could try with the label, page-ref (once more manual) but I think one would need a new label for every page. Perhaps someone else knows. I suggest to open a new thread for that.

Said this, I did not ask you an image of the document you are writing in source mode, but of your aip.ts in source mode. If you are still interested in reading your aip.ts style file, perhaps one way by which we will figure out what happens is to check both your aip.ts and your source.ts style files.

You may try those found at this page. I have only tested them on win 10, but expect no difference on win 11. Be sure to once more clear your user folder before launching these new versions, just to be sure there is no interference.

Hi @pjoyez,

I deeply value your assistance. I will try this one shortly and post the results here.

TeXmacs has proven, in a very short time, to be an exceptional tool, especially after my experience with LaTeX over the past few years.

Hi @pireddag,

Regarding the aip.ts style file, I want to clarify that I have already posted images of what I see when I try to view the source mode of AIP.ts. The image showed no code.

However, when I navigate to the file’s folder and open the AIP.ts file in a text editor, the code is displayed. I am still very much interested in understanding why this is happening and finding a solution.

By this, source.ts style files you mean one source.ts style file that is in the folder Styles? How to access it with TeXmacs?
Should I open both files in some text editor?

I hope this information helps in our collective effort to figure out what’s happening.
Thank you for your continued assistance.

ok, now please, starting from that condition, do from the menu Document -> Source -> Edit source tree and see what happens.

Yes, I mean that. It is the style file that TeXmacs uses to open .ts files.

1 Like