How to use the font bbold in TeXmacs?

I would like to write mathematical formulas involving the symbol delta
image
which is conventionally produced by the package bbold (see http://mirrors.ctan.org/fonts/bbold/bbold.pdf and CTAN: Paket bbold). I would be very grateful if you could tell me how to install the font on TeXmacs.

1 Like

Hi @xuyiqi1 and welcome to the TeXmacs community!

This font is already installed in TeXmacs. It is available as TeX Blackboard Bold Variant in the Document->Font dialog.

In this font the symbol you want is encoded as U+00B4, ACUTE ACCENT. So, if you insert the character ´ when the right font is selected, you get the symbol you want.

2 Likes

Another way to do it:

  1. Input a \vartriangle: enter this code directly, or input @ then input Tab several times to switch to the triangle.
  2. Select this character, then click Format → Font effect →Blackboard embold.

You could also create a macro:

<assign|Prism|<embbb|\<vartriangle\>>>
2 Likes

Interesting method, @re4zuaFe! It looks slightly different from the symbol in the first post, but it’s pretty close. I believe that the blackboard embold font effect is using TeXmacs’ font emulation features:
http://www.texmacs.org/joris/fontart/fontart-abs.html

1 Like

@jeroen @re4zuaFe Thanks a lot for your nice solutions. Following your methods, I get the symbols as in the picture.
image
The first one is more sufficient for my writing. Thanks again.

However, the outcome is slightly different from what I wanted (the double line is misplaced). I am still wondering if there is a way to get exactly this delta below.
image

That’s very odd. I get the same symbol as in your first post, not the mirrored one.
Just to make absolutely sure we are doing the same thing, could you please copy the following code and paste it into TeXmacs with Edit -> Paste from -> TeXmacs?

<with|font|Bbb**|\A>

2 Likes

Thank you @jeroen. With your code I get the same symbol as in my first post. I know why it happens. If I insert the character ´ and apply TeX Blackboard Bold Variant, I get what I want. But if I insert \Delta then apply the same font, I get the mirrored one.

I still have two questions. I would like to know how to using Unicode to insert symbols (like U+00B4 you mentioned), and how to insert character ´ using keyboard (earlier I just copied and pasted it from your post.) By the way, I am using TeXmacs on Windows 10. Thank you in advance.

You’re welcome. You can enter Unicode characters in TeXmacs by first doing ^q (on my system that’s Esc+q). Then you can enter the #B4 to get the symbol. I don’t know how to enter it via the keyboard. This will be system and keyboard dependent.

As @re4zuaFe pointed out, it may be convenient to define a macro for your symbol. You could also attach a keyboard shortcut to it.

1 Like

In order to get the correct semantic editing, seemingly it is better to specify the semantic in the macro. For example, I would use this one (where I also made the font larger):

<assign|Prism|<math-ordinary|<large|<with|font|Bbb**|\A>>>>

which should be closer to the LaTeX code

\usepackage{relsize}
\usepackage[bbgreekl]{mathbbol}
\usepackage{amsfonts}
\DeclareSymbolFontAlphabet{\mathbb}{AMSb} %to ensure that the meaning of \mathbb does not change
\DeclareSymbolFontAlphabet{\mathbbl}{bbold} 
\newcommand{\Prism}{{\mathlarger{\mathbbl{\Delta}}}} 

Then you could simply input \Prism to get this symbol, and I tested the following codes

<math|<value|Prism><rsub|R/A>>, <math|X<rsub|<value|Prism>>>
2 Likes

Unfortunately, TeX Blackboard Bold Variant doesn’t provide lower-case letters for Greek. The font bboldx can be an option, but I cannot install it in TeXmacs. Do you have better solutions?

Looking at the font file (using Fontforge), shows that lower case greek characters are in fact there, but are categorized under different character.

E.g., lower-case delta can be typed as < followed by Tab. TeXmacs probably needs some hints where to find these character to fix this, but I don’t know how to do that.

1 Like

Thanks a lot. But I couldn’t reproduce alpha, beta, and the letters in the bottom line, for example, lower-case xi. Could you explain a little more?

It’s best to install Fontforge and use it to open the file bbold10.pfb in TeXmacs/fonts/type1/math. There you can see which Unicode character corresponds to the symbol you are after. Then you need to generate that symbol somehow (this is platform-dependent) and copy-paste it into TeXmacs.

1 Like

Thank you so much for your guidance. I can type in the proper characters now.

I have also used FontForge to check the font bboldx. The font file BBOLDX-Regular.pfb shares almost the same list of blackboard bold characters with bbold10.pfb, and most importantly, each of which is categorized under the correct Greek character as expected. Should we see the strange behavior of bbold10.pfb as a bug? Could we replace it with the more updated font bboldx in a future version of TeXmacs?

By the way, bboldx has another advantage of extending the original to a set of three weights with the original.

1 Like

Thanks, bboldx looks very interesting! I would definitely submit a feature request on Savannah to either add the lowercase of bbold or substitute bboldx.

2 Likes

I noted sometime myself too the wrong appearance of the \in symbol. This is due to the fact that TeXmacs use a virtual glyph for it, not recognising (for some reason) that the font has the correct glyph and there is no need to simulate it. Also, there seems to be some small bugs in the PDF rendered which produce misalignments of the various pieces which compose the virtual glyph. We should have a bug report for this because it affects also other simbols (I remember to have seen some misalignment for root overbar in the Computer Modern font when you encapsulate a lot of square roots).

2 Likes