Inserting a newline in beamer titles and how to center them

Hello. How do I insert newlines in a beamer title and how to center the title? (when I change the paragraph alignment the linebreaking fails and the title goes past the end of the page) Is it possible to add authors, affilitions, etc. to the presentation like in regular documents? Thanks.

I managed to figure out the newline part. You can insert a newline with the \\ macro the same as in LaTeX.

1 Like

Format -> Break -> New line

I do not know, for me it is centered by default :slight_smile:
I have not been able to change paragraph alignment using the menu, but this worked:

<with|par-mode|left|A longer title<next-line>split into two lines, the second
of which wraps around>

Yes (the plus sign in the ribbon)

It looks different from <next-line>

I have no clue. But the Format -> Break -> New Line does break the title for some reason. It works in the text but the title is somehow special.

If I’m inside the tile I have no + sign on the ribbon.

Pls. take a look at this:

Yes, but is that the Beamer style? Because I only have problems with the Beamer style. Maybe I was not clear about this.

Yes it is. Can you post here a screenshot of your title?

Interestingly. If I create a New Document and create a title in default style and then switch to Beamer, then everything works. But if I switch to Beamer first and then add the title, then the tags are wrong.

Here is a screenshot of a new document switched to beamer style and title added:

And here is the one that is correct (by filling in the title in default style and then switching to beamer):

Is this the same with you or I just deleted some macro accidentaly? :smiley:

Clicking the Title button adds only <tit|> instead of <doc-data| <doc-title|>>.

I can switch to Beamer first, and then add the title, or do the opposite, and it still works.

Maybe try and regenerate the user directory (.TeXmacs in the home directory if on Linux)? If you delete it, TeXmacs will regenerate it at the next program start. You have first to save your personalizations (e.g. the plugins and packages you added, you personal initialization file my-init-texmacs.scm file)

What version do you use? I tried wiping the ~/.TeXmacs directory but it didn’t help. I also tried to copy the beamer package from another download but that did not help either.

At the moment I think the .deb package that I got from the website. Before that I used the static binary (and by the way thanks for making me notice in the other thread that I may use it again and be able to run sessions).

I would try a reinstallation (saving what you want to save from the .TeXmacs directory), if that does not work we can think more.

Will do some other time. Its getting late here. I can make it work by creating the title in the default style first. For some reason the Title button adds a slide title instead of a document title. I think <tit|> is the slide title macro. I tried reinstalling it did not help. I don’t want the .deb version because sessions didn’t work the last time I tried. I’ll look into it sometime. Maybe the .deb version can be patched by copying some files from the general GNU/Linux distribution files.