Keyboard shortcut non effective

I recently installed TeXmacs on my new computer Asus VivoBook.
Impossible to obtain \sqrt with the shortcut Alt+s.
What can I do ?
Thank you for help !

Are other shortcut working? Is Alt+S working in other software? One possibility is that the key combination has been intercepted by the OS. Maybe you can disable this in some system setting.

Other shortcuts seem working perfectly : Alt+$, Alt+&, Alt+f are all correct.

I’m afraid it’s my new computer that has a mechanical problem with its keyboard. But a computer repairman told me that if the “alt” and “s” keys worked separately, the keyboard was not to blame.
The fact is that I waste time typing \sqrt instead of alt+s in my many texts to write (I am a volunteer teacher).
Thank you for your kind help !

My computer works with Fedora Linux 37 KDE. I tried also PCLinuxOS in two ways : Live DVD, and virtualized with VirtualBox. The result is the same : the shortcut Alt+s don’t work either.
I think that my keyboard, even “brand-new”, has a mechanical problem.
How to create a new shortcut in TeXmacs (even different from Alt+s), then ?

I would try a program that shows the keyboard input (I used Screenkey on Ubuntu which seems nice).

TeXmacs and this shortcut (Alt+s) work well with Gnome and XFCE.
With Fedora 37 KDE or PCLinuxOS KDE, same malfunction.
I don’t understand why.
Thanks for your lights !

It is possible then that KDE is intercepting Alt s as a system shortcut. This pages seems to indicate there might be such a shortcut:

Try to disable that shortcut in KDE’s settings. If that doesn’t work, you can try TeXmacs’ alternative shortcut for square root: Esc Esc s