Strange behavior when centering tabular

I was trying to center a “plain tabular” using the Table Properties -> Horizontal Alignment -> Middle but the results seem incorrect. See pictures below"


The tabular is not centered, but just ends up outside the page. Is this a bug, or am I doing something wrong? This happens in both Mogan and TeXmacs, Mac and Windows.

Btw, I can center the tabular using Insert Prominent Text -> Centered.

1 Like

same here.I was trying to center a table in a beamer page, and get the same result as yours. I’m also struggling to add a center title at the top of table…no clue right now

It may be that the menu in Table properties refer to the alignment of text within table cells, but it does not work well either for that or for what you intend to use it for. Perhaps it is best to submit a bug report at The centering of the whole tabular is obtained either as you did it or with paragraph alignment.

1 Like

Hi @Kontinuation and welcome to the forum.
You might get the title at the top of the table with the environment big-table, placing the caption on top—there is an entry in the big table menu that you access through the wrench symbol when you are in the big-table environment. One can adapt the big table environment if you do not like how it appears (e.g. remove the word Table from the caption).
Otherwise by centering paragraphs; it is also possible to adjust the spacing between paragraphs with the par-par-sep environment variable, and I think that it is possible to automate this with a macro or a keyboard shortcut (tried the macro only, the keyboard shortcut may be more convenient).
Pls. ask if you need more details.


Thanks for your help :smile:, the big table is what I needed, although its initial look is not desirable(i.e i don’t want the "Table " caption and number and the " . " sep, just a plain title), but it takes no much effort to customize it.(for someone else who come across the same trouble, just right click on your table, in “preference” option shows a lot of sytle control parameters:figure sep, table text…).

You could easily deactivate “Table” resp. the numbering by clicking the icons T resp. IV on the focus toolbar.

Hmm, I don’t think so because there’s a different menu item for text alignment in the focus bar. Also, according to the manual on tables:

Similarly, you may specify how the table itself should be aligned with respect to the surrounding text. This is either done via the Table→Horizontal table alignment and Table→Vertical table alignment submenus, or using keyboard shorthands of the form ⌘T⇧Hx or ⌘T⇧Vx. Here x represents L for “left”, C for “centered”, R for “right”, B for “bottom” and T for “top”.

You may take a look at Section 5.4.4 of The Jolly Writer for a clearer explanation of these alignment options.