Suppressing ToC Title in Page Headers

I am currently working on a book document using the Tmbook style. I recently added a Table of Contents (ToC) to my document. However, I noticed that after doing so, the ToC title text started appearing in the header of every odd page.

I would prefer to suppress this automatic insertion of the ToC title and I would like to display the author’s name in these headers.

Additionally, I observed that if I delete the ToC, the last section heading is inserted on every odd page. In my case, it is the appendix. This behavior is consistent across all book styles, leading me to believe that the issue does not originate from the style files.

Interestingly, when I manage to fix the odd page header by inserting a new ToC, the ToC heading starts to appear in the header of every even page. I am unsure where I am making a mistake.

Could anyone guide me on how to suppress the automatic insertion of the ToC and instead display the author’s name?

Option Document > Page > Headers is also not working.


After doing a lot of things I realized that this was due to the fact that I didn’t have Chapters except for ToC and Appendix :woozy_face:
I used only sections, but no chapter and as soon I added a chapter after ToC, i.e. Introduction this issue disappeared :slight_smile:
So, that was that