TeXmacs crashes when selecting semantically

I don’t know whether it is a general bug of TeXmacs or a specific bug of this build. Here is a MWE:


When I use the mouse trying to select this Rightarrow: click the point right after this symbol, keep clicking and move to the left, TeXmacs gets stuck and is then killed. I tried to run with texmacs -d -V, but failed to get any useful debug info.

I can’t reproduce this. What build is that?

Latest appimage under Debian 11. I am not aware of any way to debug. It was killed silently. Nothing like segfault.

1 Like

I tried in a virtual Debian 11 with the appimage. I can’t get it to crash, I’m afraid. Can you crash it in an empty file with only the snippet you posted, or is there anything else in there?

I did that in the empty file (that is how I isolated the issue). I will try to move .TeXmacs to try to run TeXmacs in an empty environment.

1 Like

I studied and find a more precise environment: this happens once you enable “Semantic editing” and “Semantic selections” (these two options are important for me).

Thanks for investigating! I can confirm this now. Would you mind putting this into a bug report on Savannah?

It only seems to happen with double and triple horizontal arrows. Not with vertical or single arrows. It also happens on Fedora with Qt5. Only the arrow seems important, e.g. this also crashed on selectiong:


I find that this has been reported before, a quite old bug (strange that I did not encounter this before).

1 Like