Texmacs on Debian 11 (Bullseye)

Hi all. I started using TeXmacs a few months ago on Debian 10 (Buster). I upgraded yesterday to Debian 11 and can’t install TeXmacs again most likely because of the updated Guile libraries. Is there a release (*deb) file in the works for Debian 11? At the moment i’m having to use TeXmacs on an older system.

Hi @alyosha and welcome to the forum!

This was discussed on the mailing list recently. I’ll quote the response below:

The current TeXmacs is built for up until Debian 10, so for Debian 11, you need either compile it yourself (Debian Maintainers’ guide has some information about backporting packages), or use the generic Linux packages temporarily. I think that this will be resolved soon.

“Soon” needs to be weighted in the context of a small team—it might be more than one year.
Said this, I have used the static binary only and it works very well (it even installs an entry in the Ubuntu start menu).

Thanks for the prompt and helpful replies @jeroen and @pireddag. I just installed the generic Linux package, and it took so much time for TeXmacs to start that I thought it wasn’t working, so I aborted the process. I tried again. It took its time once more, however subsequent starts of the program were quite fast. Coming from the LaTeX world like so many here, it’s refreshing and eye-opening to use the TeXmacs approach. A million thanks to Joris and all those who are involved in developing this wonderful piece of software.

1 Like

You could try the packages built by @pjoyez :

https://software.opensuse.org//download.html?project=home%3Aslowphil%3Atexmacs-devel&package=texmacs

They are also only built up until Debian 10, so they may fail in the same way. I don’t know if there’s a difference between these and the packages on texmacs.org

Another option would be to use the AppImage:

I was using @pjoyez’s repository for Debian 10, but it failed on Debian 11. Thanks for the AppImage suggestion. It looks like the best option for me until the repo packages are available. After a while, the TeXmacs from the generic Linux packages started slowing down again. Let’s see how this one goes.

1 Like

I don’t think that it might be more than one year, given that the binary works on Debian 11. The only thing to do is to build the package under Debian 11 (no coding is necessary), which should be done in the next release.

It is possible that I have quite confused ideas on the topic.
Does a Debian package depend on libraries, which are installed in the OS? As far as I understand, the binary can be made so as to include all of its dependencies—so I get in Ubuntu a binary which depends on Guile 1.8 and I can keep the Guile 2 library which is default in Ubuntu. But for the package?

It depends on how the packages are maintained. Concerning guile, if you perform apt-cache search guile, you will find packages with name guile-2.0 and guile-2.2, which indicates that these different packages might co-exist on the same system. Note that this is also the case for Python 2 and Python 3. You can also look at OpenJDK.

I have some experience with Ubuntu, not enough with Debian. In Ubuntu, I tried installing the package from https://www.texmacs.org/tmweb/download/linux-packages.en.html#ubuntu and the package manager told me that it wanted to uninstall guile-2.2 (I forgot the details).
I found on StackExchange this answer that to me looks believable: https://superuser.com/a/877729

This experience seems outdated. I downloaded the latest deb file and found no dependency about guile. I think that Guile is embedded in the current TeXmacs packages, cf. https://github.com/texmacs/texmacs/commit/eee5a00c65dcf870f0ca65082333f41f7a4ec470

How about try this branch:
Guile 3 Integration for GNU TeXmacs 2.1 by darcy-shen · Pull Request #54 · texmacs/texmacs (github.com)

I’m using GNU TeXmacs (built with Guile 3) on Debian sid. It works fine.

You are right, and thanks for letting me know. I installed TeXmacs 2.1 on Xubuntu 20.10 using the package and it worked.

I realized that I do not recall whether I used the package or the Ubuntu repository ( http://www.texmacs.org/tmweb/download/linux-repos.en.html#ubuntu ). Perhaps it was the repository, but I am not going to test it now.

Please give me some time, I will let you know.

It is the same for the repo (in fact, since I myself use the repo, and after looking at the result of apt-cache depends texmacs, I find that guile-1.8 or something similar is no longer there).