TeXmacs Shortcut for Toggling Equation Numbering on MacOS

Dear friends,

I am encountering an issue with TeXmacs on my MacBook Air, specifically with the ⌃# shortcut used for toggling between numbered and unnumbered equations, as described in “The Jolly Writer” (Chapter 5). This key combination seems to conflict with a default macOS screenshot command (command + shift + 3). I have tried modifying my system shortcuts, but the issue remains unresolved. Could you kindly provide any suggestions or guidance to fix this?

Thank you for your support.

Best Regards,

If remapping the key combination assigned to (numbered-toggle (focus-tree))) did not work, it is still possible that a different key combination works, so you might try that.

On the other hand, the default mapping is

("structured:cmd #" (numbered-toggle (focus-tree)))

and structured:cmd on the mac corresponds to "A-" (see line 159 of texmacs/keyboard/prefix-kbd.scm). You may try that as well.

1 Like

Hi Pireddag,

Thanks for your help. I modify the mapping in



("#" (numbered-toggle (focus-tree)))


("C-#" (numbered-toggle (focus-tree)))

to make it work.

Best Regards,


It is best to put the modifications into one’s personal initialization file, my-init-texmacs.scm (in the local TeXmacs directory, pls. ask if you need help to find it). In this way they are preserved upon updates of the program.

1 Like

It is a solved problem in Mogan Research v1.2.x.


You may try Mogan Research v1.2.3-rc3 (just released). And I will release Mogan Research v1.2.3 before 2023/02/01.

1 Like

Hi Darcy,

Thank you Darcy.

Best Regards,

Hi Preddag,

Do you mean

Click Developer → Open my-init-texmacs.scm

and then copy

(“F1” (interactive docgrep-in-doc))
(“S-F1” (interactive docgrep-in-src)) ;; FIXME: S-F1 should be ‘What is This?’
;(“M-F1” (load-help-buffer “about/welcome/welcome”)) ; Conflict with devtools

(“C-#” (numbered-toggle (focus-tree)))


My my-init-texmacs.scm is empty.

Thank you.

Best Regards,

Yes, I mean that. Also you could try Mogan, or you could see how the code for that is organized in Mogan.

1 Like

Mogan Research v1.2.2 works fine too. Because I switched structured:cmd from Option to Ctrl.

Because structured:cmd # is option # which might not work properly on macOS.

But structured:cmd tab does not work in Mogan Research 1.2.2 because Option+Tab works fine on macOS but Ctrl+Tab does not work on macOS. I just solve the problem by adding A-S-up and A-S-down for structured variants circling. (Please wait Mogan Research v1.2.3, it would be the best TeXmacs distribution!)

See https://mogan.app/guide/Mogan_versus_TeXmacs.html#structured-variants-circling-since-v1-2-3

1 Like

I will discuss with Joris on the shortcuts changes I made in Mogan Research. It is necessary and there are little risks to change the shortcuts.

1 Like