TeXmacs starts but don't show anything

I tried installing official TeXmacs and slowphil’s version on windows 10, but none of them seem to work.

when I start the program it shows as running on the task manager but it doesn’t open any window and can’t do anything, only close the program from the task manager.

Any ideas why this happens?
I installed on the same machine under ubuntu and it works but wanted to use it also on windows

You could try run texmacs from the command line (I am not familiar with Windows so I don’t know precisely how to do that) with the parameters like texmacs -d -V, then you could see the command line outputs to diagnose.

I tried it now and unfortunately on Windows there is no output to the command line (either with the command line or with Power shell), so it is not going to give the user any information.

If there is no idea on how to debug this malfunctioning here on the forum, one possibility is to contact directly Denis Raux, who is knowledgeable on the Windows port (contact information is public at https://www.texmacs.org/tmweb/contribute/team-denis.en.html).

I just discovered there is an undocumented command line option -log-file that can be used to specify a log file for output.

This also works on Windows, so you can do texmacs.exe -logfile texmacs.log and look at texmacs.log to get any output.

I have had this issue quite a bunch. For me it happens when a second monitor was connected but then gets disconnected, and the application launches (perhaps) off screen.

Solution for me (Windows): left click the application window in the task bar, which will open the list of currently-open windows in a preview pane. Then right click the window you want, then click maximize. You now should be able to drag it around and resize it like normal. Hope this helps!