TeXmacs under Wayland

I now switched to Wayland (more precisely, the swaywm). There seem some issues of TeXmacs under Wayland:

  1. I don’t know why: TeXmacs seems to ignore the environment variable QT_QPA_PLATFORM. In particular, if I disable XWayland, I can no longer run TeXmacs directly, even after setting export QT_QPA_PLATFORM=wayland. A workaround: run texmacs -platform wayland.

  2. I enabled the global scaling in swaywm (so that I do not have to set HiDPI for every app). It seems to me that the TeXmacs rendering is then blurry (the menu is however sharp, after setting -platform wayland).

This post might be interesting as well for the texmacs-dev mailing list (info on the mailing lists at https://www.texmacs.org/tmweb/home/ml.en.html).

Google tells us that there was a post https://lists.texmacs.org/wws/arc/texmacs-users/2020-07/msg00064.html years ago but without follow-up.

Perhaps then a message should reference that older one :wink: