Zoom with touchpad?

Frequently I find myself zooming in / out of the document by pressing Ctrl and scrolling with the touchpad (via two finger scrolling, which emulates the middle scroll button of a mouse). This is bad, because when I Zoom in a document for which the “Page rendering” setting is set to “screen”, it messes up the layout of the document.

I would like to see this zooming feature fixed.

But in the meantime, is there a way to disable zoom via Ctrl + scrolling?

At first sight this seems a bad bug. I tried to replicate it on Linux Ubuntu, but I do not know how to set “Page rendering” to “screen”, could you please give me instructions.

For disabling zoom via Ctrl + scrolling, sorry, I do not know, as I do not know how to refer to the mouse in Scheme. If one does, then I think assigning Ctrl + scrolling to (noop) should disable the “mouse shortcut”.

Document menu -> Page -> Select “screen” under “Page rendering”

Yes, this is very annoying for me too. Seems that this behaviour appeared with Qt5, I guess due to some changes in these libraries. I think a bug report has already been filed by Basile.

Can you link the bug report?

In the meantime it might be safer to just disable this feature.