Double primes in math input

If you define a function in giac, you can use prime and double prime to find the first and second derivatives; for example,



However, on math input in TeXmacs, the double prime turns into a quotation mark

Is there some way of avoiding this?


" and ´´ are different. Did you try with the two?

(I meant to send this to the list.)

I type in two primes, but it gets automatically turned into a quotation mark.

I have not been able to reproduce the behaviour you describe, in that pressing prime twice results in two primes. Which “look and feel” setting holds for your TeXmacs?

This said, if you press the tab key after TeXmacs has inserted the “shortcut” symbol normally reverts the typeset output to the keys you typed—could you please try that? Id est, instead of typing '' type ''tab.

My TeXmacs is using the default look and feel.
Using TAB fixes things; thanks!

Happy that it does :slight_smile:

On which OS are you though? The default is different in different OSs as far as I know.

By the way, welcome to the forum!


I’m using Debian 12.

And thanks!!