Plugins sessions issues

Hi.
I use Texmacs 1.99.11 on windows 10, 64 bits.
I have some troubles with the Texmacs plugins (I took the precaution of indicating all the paths in the environment variables) :

  1. When I load a session with the plugins python, asymptote, graph, gnuplot I recieve the message “python: can’t open file ‘C:\Program’: [Errno 2] No such file or directory”. And “Busy” (“En cours” in french) is displayed above the Python (or the other plugins) prompt.
  2. When I load a session with the plugins Dratex, Feynmf, Matlab, Shell, Texgraph, XYPic. “Busy” is always displayed above the prompt and everything is blocked.
  3. The plugins that work fine with me are : Scheme, Giac, Maxima, Yacas.
    I hope someone can help for these issues.

best regards

1 Like

Thanks for you report.

It’s my fault to introduce the bugs. I’ve fixed it via:

And I made a preview Windows version for GNU TeXmacs using slowphil’s build definitiion:

https://share.weiyun.com/5kka5R7

You may use this version before the next release of GNU TeXmacs 2.1.

I maintain the plugin status here:

There are too many plugins to maintain. Currently, we can not guarantee that all the plugins work fine.

Thanks you very much Sadhen.

Unfortunately the link (https://share.weiyun.com/5kka5R7) don’t work for now.
I’ve modified the init scm files (in my texmacs $Home directory) the way you explain and now most of the plugins work fine. Thank you very much.
The plugins that don’t work yet are : Dratex, Feynmf, Matlab, Shell and Texgraph.

Best regards.

I will fix Dratex/Feynmf later.

Currently, shell should only work for Linux/Unix. I will check if it is disabled under Windows.

I have uploaded the binary to Github:

https://github.com/sadhen/files/releases/download/v1.99.11_r12175/texmacs_installer_v1.99.11_r12175.exe

Hi:

I have just tested the dratex plugin and i find this

Traceback (most recent call last):
File “C:\Users…\AppData\Roaming\TeXmacs/plugins/tmpy/session/tm_dratex.py”, line 33, in
current = DraTeX()
File “C:\Users…\AppData\Roaming\TeXmacs/plugins/tmpy\graph\dratex.py”, line 22, in init
the_plugin_path = get_plugin_path(name)
NameError: global name ‘get_plugin_path’ is not defined

I am not sure if this is the place to publish this, if it is not just let me know

Pedro

I made a mistake for the preview release: https://github.com/texmacs/texmacs/releases/tag/v1.99.11_r12359

I have fixed it. Well, fortunately, it is a preview release.

You may report it here: TeXmacs Pre Release (v1.99.11_v12359) for Windows

Hello,

I had always the ‘Busy’ text when I tried the XYpic plugin. Luckily I found the cause of the problem. I was using a texlive installation for tex/latex and by examining the content of the xypic.py I noted that the document class ‘standalone’ was used but this document class was missing from my texlive distribution. After installing the ‘standalone’ tex package the problem was solved (I use open suse and just had to use yast to install texlive-standalone).
Hopefully this helps other users that encounter problems with XYpic

Marc Mertens