[Solved] Installing Texmacs on Kubuntu 22.04 (I keep racking my brain to it)

Hello,
EDIT : sorry in advance for my really bad english
First of all, I don’t know if I am supposed to ask this in this forum, and with this tag. So if not, please tell me where I am supposed to do it.

So, since I had some problems with GNOME on Ubuntu 20.04, I moved to Kubuntu and installed the 22.04 version. And since I am a heavy user of Texmacs, I tried to install it, but for now I have encountered just misery and sadness.
I will tell here what I tried to install it and why it didn’t work.

First of all, Texmacs doesn’t provide an Ubuntu 22.04 version ready to install on the website.
So I installed the “static binary package” for x64 Linux, and it seems to work, until when I tried to save, I had a blank screen, the blank screen is only solved when I open texmacs as root user But if I put sudo texmacs as “exec” for the .desktop file, this file won’t open anymore.
Anyway, I hope there is a better way to install Texmacs on such a common distro as Ubuntu.
After that, I tried to install the 21.10 version, the latest but after installing it, nothing changes, I mean, there is no app installed. Weird.
After that, I tried to install the 2.1.2 from the git repository, but the installation needed guile, I installed guile 3.0, not compatible, I installed guile 2.0, not handled, I installed this, didn’t change a thing (not recognised, I think it’s because guile-dev). And when I ended up saying to the configure file that it could run guile 2.0 instead of 1.8, it told me that freetype is missing.
Same sh*t, I installed freetype2-demos, and it didn’t change anything.
After that I tried to install this even if I’m not sure that it was what I needed. And, it said that it has the same dependencies problems as the 2.1.2 github version (which is logical).

So to solve my problem I think that this last download thing is what I need, but I don’t know how to properly (and workingly) install the dependencies that are missing.
To remind you I am on Kubuntu 22.04.

Thanks in advance for any help.

I suggest you try again the static binary using gksu instead of sudo in the .desktop file; I do not know myself why this should be but I recalled it being necessary from a past web search so I did a web search now and I found https://stackoverflow.com/a/23500488 on the topic.
If gksu does not work I think it is still worth investigating and figuring out how to start a graphical program as superuser.
Of course if someone else gives you a more principled answer rather than my “web-assisted” one it is better.

And welcome in the forum!

I tried again the static binary, but it seems to work now, I mean without the root need, I do absolutely not know how, but it works.
So I will use it until we have a proper ubuntu version, or until someone tells me how to install this version, if it’s relevant.
Anyway, thank you pireddag.

EDIT : the root problem came back :upside_down_face:

I’m really sorry to bother, but is there anyone that have the answer to my problem ?

What happens if you do the gksu thing? @mgubi, @jeroen or @sadhen could perhaps help you better than me, but in these days they are not present in the forum and the suggestion I gave is the only direction in which I am able to move. If gksu does not work we can figure out how to make the idea work.

I would strongly advise against using sudo as a solution, as TeXmacs documents could execute commands on your system as root.

It would be useful to have some more details on what is happening when you save a file. Could you start TeXmacs from the terminal and see if any error messages are printed there?

1 Like

Sure, here are what I get :

This build in the screenshot is opening the system’s save file dialogue window (visible behind the blank save window). Is that window accessible or does the blank window always stay in front?

The save file code has recently been changed to use a custom dialogue on Linux, which should fix this:

This commit is included in 2.1.2, but the builds on the website seem still to be 2.1.1. Until they are updated, you could try the AppImage from here:
https://download.opensuse.org/repositories/home:/slowphil:/texmacs-devel/AppImage/

If you want to try compiling yourself, perhaps these notes can give you some hints on what libraries you need to install (as the Raspberry Pi OS is Debian-based, like Ubuntu):
https://texmacs.github.io/notes/docs/compile-texmacs-on-raspi.html

Specifically, for freetype, try installing libfreetype-dev.

There seems a lag in buildings of Debian (current stable) & Ubuntu.

Hi,

So, the appimage won’t download for some reason, manually the download won’t start and with curl, the download starts but when I try to execute it, it gives this error : 2022-07-24_16-05.

I tried to compile like by myself, but the installing of Guile create problems : the errors on the terminal.
And then when I try to install texmacs anyway, it says that Guile 2 is not compatible, same shit.

If possible, could you manually send me files of the appimage so I could download them.

Thanks for the work you do to help me.

Compiling GNU TeXmacs on Ubuntu 22.04 is not an easy task for everyone. Because we have to compile GNU Guile 1.8 first.

You may try to compile Mogan (my fork of GNU TeXmacs):

It is much easier to compile and make a deb package by yourself.

You can verify the checksum for the downloaded file with sha256sum texmacs-latest-x86_64.AppImage.

I get b62ed8d8a6d294cbfe14d3741e036bd57e9b7fcedc64486f4f4975782fd9057f ./texmacs-latest-x86_64.AppImage

Although, @jeroen and @sadhen, installing TeXmacs on Ubuntu ought to be straightforward so that anyone that feels like trying it can do so immediately.

If I understand correctly, the previous Debian maintainer was recently retired. It would be expected that there might be some issues and lags on Debian/Ubuntu building.

@jeroen, I get different checksum every time I curl it, and I still can’t download the file without it.
So it would cool to have some copied files from you.

@sadhen, sorry but can you tell me how to compile from yours, I am a newbie to this kind of things. Thanks in advance

We should get this working for everyone instead of sending files around.

Please inspect the file you have downloaded with an editor, you may be downloading some HTML instead of a binary. Also try wget, this works for me:

wget https://download.opensuse.org/repositories/home:/slowphil:/texmacs-devel/AppImage/texmacs-latest-x86_64.AppImage

After downloading, you need to add an executable flag to the file (chmod u+x texmacs-latest-x86_64.AppImage)

Also, I have tried the packages for Ubuntu 22.04 from here. They work perfectly for me. It would be useful if you could provide some detail on what is going wrong for you. Did you add the repository or did you just download the binary package?

To be honest, I think the TeXmacs website should just link to the repositories by @pjoyez on OBS. They should be much easier to maintain (with the option to have several maintainers), and they provide automatic updates.

Once we have moved away from Guile 1.8, it should also be feasible to get TeXmacs packaged in Debian again.

1 Like

sorry but can you tell me how to compile from yours, I am a newbie to this kind of things. Thanks in advance

See https://github.com/XmacsLabs/mogan/blob/main/.github/workflows/ci-ubuntu-20.04.yml

Once you have installed all the dependencies, you can use packages/debian/package.sh.

I also had problems using the debian package linked on texmacs.org. The file chooser dialogues did not display correctly and interactive sessions usually led to crashes.
My own build doesn’t have those issues but is sluggish probably due to lack of certain optimisation. Now on the OBS appimage and it has been quite smooth.

@jeroen, I tried to add the repository to install it, and it seems to work, same thing for the appimage (yes I was downloading the html :sweat_smile::sweat_smile:).
But now I get new errors, like this when I try to save a file : 2022-07-25_07-05