TeXmacs on Gnome, Icons not visible in dark mode

Hey, I have an issue with dark mode on Gnome.

The first is, that I am running in dark mode, which seems to confuse the interface. The icons are displayed with dark background, but since the icons themselves are not dark and therefore not visible

I am also happy to set Texmacs to light mode somehow and exempt it from the dark mode, if that is possible.

Have you tried to select : Theme -> Dark in the Preferences (first pane)?

Thanks, that worked!
image
The background of text in the popups have a slightly odd colour and the lowest pane (See “Line” or “Opacity”) is kind of cutt off. But these are only artifacts I think. Everything is usable and can be read like this

Does the cutoff appears also in light mode?

Yes,

image

But it is not much of the problem. If you hover the icons the full text will show (see Generic here):

image

And it is readable even in the cut-off form.

This is really ugly anyway. Sorry for this. Qt interface has proven to be an hassle to maintain. I’m looking for alternate solutions.