TeXmacs + Xcas-GIAC

I have installed TeXmacs and Xcas-GIAC on my computer, powered with Linux Fedora 33.
I proposed to use TeXmacs to display in prettyprint the responses of Xcas to my calculation commands.
But TeXmacs did not connect to GIAC, and I could not to compute anything.
My Xcas-GIAC runs well, however.
What can I do ?
Thanks for your kind help !

Welcome AtomeKid.
Could you describe in more detail what you have tried? Do you mean you inserted a GIAC session using Insert->Session-> Giac? Do you get any error messages?

I’ve tried on Fedora 33 and the session seems to respond to commands.

I have no explanation for the fact, but now my TeXmacs+Xcas-Giac run well together !
Yes, I used Insert->Session->Giac.
Is that another way to insert a calculation in my document, and keeping only the issue given by Xcas-Giac ?
Thanks, sorry for my bad English !
friendly yours.
A. K.

Glad that things got resolved! Let us know if the problem should show up again.

You can use Insert->Fold->Executable if you want the code to be hidden and only the result to show in the document.

Hi @jeroen, could you please give a try to Insert->Fold->Executable? Since yesterday I cannot get it to work, I get a Ghostscript crash.

Hi @pireddag, it still works for me. Which plugin is broken for you? Could you attach an example?

Here is an example (but none of the plugins work, I think the issue is caused by Ghostscript) - it works under Windows, but not in Ubuntu. I have a “crash file” for Ghostscript under \var\crash for a different instance of the same issue, I assume it is the same for this (where I do not get the crash file).






Following up on the answer that @jeroen gave you, you might take a look as well at https://texmacs.github.io/notes/docs/embedding-tikz-figures-short.html, which shows the “executable fold” environments; I expect it to work for Giac in the same way it works for TikZ (in stead of Insert→Fold→Executable→Graph you have to do Insert→Fold→Executable→Giac)

Do you have an idea of when this behavior changed? Looking at the commits in recent weeks I don’t see an obvious candidate for what may cause this.

The earliest I have noticed the “ex-folds” (let’s call them this way) not working is two days ago, but it is months that I had not been using them.

I got an answer to the question I placed on the mailing list (http://lists.texmacs.org/wws/arc/texmacs-users/2021-02/msg00013.html), deleted my .TeXmacs folder and now the fold executables work again, although it seems that something is still wrong—copying from the mailing list:

I got the error message (from TeXmacs) “gs_to_png failed for ramdisc.//image.ps”, but I am not sure that it was not there from previous attempts; on the other hand there has been another Ghostscript crash with again “gs crashed with SIGSEGV in gx_default_fill_path()” in the /var/crash/ _usr_bin_gs.1000.crash file.

I will investigate what happens with Ghostscript, if you have any ideas please let me know.