Install TeXmacs with Maxima on mac with M1

I can’t correctly install the Texmacs front-end program on my mac with M1, I can’t find anything on the official website. I’ll explain my problem better; I need to use Texmacs with the CAS MAXIMA program; in the maxima site it is explained how to install (Maxima) on the M1 and in fact I can (it is installed correctly because on the terminal typing “maxima” opens the program) but once “installed” Texmacs does not show me maxima. In particular, opening Texmacs and going to Insert> session> MAXIMA is not present. I think there is an error with Texmacs as there is no updated version for M1 it is emulated by Rosetta and maybe there is some Path error. Someone manages to install Maxima and TexMacs and display in the latter (texmacs) “insert> session> Maxima” on the M1?

Hi @marcomolisano and welcome to the forum.
I do not have a Mac but maybe we are able to find out what is happening and use Maxima with some debugging. We are going to follow the ideas of Problem installing Julia plugin in TeXmacs (Windows).
As a first step, you could try and do “Tools->Update->Plugins” (please do it more than once, TeXmacs might find new plugins up to the fourth or fifth “Update”).
If that does not work, the second step is debugging using a Scheme session. You should open a Scheme session in a TeXmacs document—from the menu: Insert->Session->Scheme (entry at the top of the Session submenu).
Once in the session, please enter (url-exists-in-path? "maxima") and write here the output.
Hopefully we find out how to make the Maxima plugin work for you.

G.

1 Like

thanks for the help but i tried both ways but nothing

Ok. The command (url-exists-in-path? "maxima") is not a way to make the Maxima session available, but the first step to find out what is happening. When you tried that, what was the output?

it is not clear to me what I have to write after insert> session> scheme … Once this is done, Scheme] (in green) appears on the screen what should I write?
If i wirte <url-exists-in-path? “maxima”>, texmacs writes <primitive-procedure url-exists-in-path?>

Doing Tools->Update->Plugins,nothing is happening. (ita?)

The parentheses are important here. You need to put ( and ) around the expression you type. The command needs to look exactly as in the post by @pireddag:

(url-exists-in-path? "maxima")

ok thanks, if I insert that string with () it returns me

#f

Right, so TeXmacs can’t find Maxima on its path. Could you please do

(getenv "PATH")

in the Scheme session and check whether the path to your maxima executable is in there?

I’m suspecting this is another issue of Mac apps not seeing the same environment as the terminal.

thet texmacs command it returns me:

“/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/TeX/texbin:/Library/Apple/usr/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/axiom/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/eukleides/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/feynmf/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/lisp/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/lush/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/maple/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/mathematica/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/matlab/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/maxima/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/mupad/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/r/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/reduce/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/scilab/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/shell/bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/texgraph/bin”

there is
bin:/Applications/TeXmacs.app/Contents/Resources/share/TeXmacs/plugins/maxima/

and thereis also matlab (for example) that which is not there in insert>session

You need to add the location where your Maxima is installed to the PATH environment variable that TeXmacs sees. I don’t have a Mac, so I can’t tell you how to do that. This might help:
https://stackoverflow.com/questions/135688/setting-environment-variables-on-os-x

If you can start maxima from a terminal window, then which maxima should tell you where it’s installed.

Thanks to jeroen for the help, I tried to see the link but it looks old to me and I think it has another problem.
If anyone can guide me on how to fix this PATH problem I would be really so grateful.
Unfortunately I am not an expert on these things…

please someone help me i need to use texmacs with maxima…

I have got the impression that you need to find someone who is using the Mac, even if they do not use TeXmacs, to help you with the path.

In these days @mgubi and @vdhoeven (both Mac users, and the ones who could have helped you) are not posting, so perhaps you could find somewhere else someone who tells you how to add the necessary path for Maxima (any forum where people answer Mac questions), and after we have that we can get TeXmacs to recognize Maxima I think (I am taking for granted that once you put the Maxima path onto the PATH environment variable, then

(url-exists-in-path? "maxima")

will return #t and hopefully the rest of the plugin code will work and you will be able to use Maxima.

If Maxima is on your path in the terminal (I.e. if you type maxima in a terminal, then the program starts), then you could try to start TeXmacs from the terminal as well. It should then inherit the environment from your shell. I don’t know how you would go about executing TeXmacs from the terminal, though, as I don’t know where MacOS puts executables.

I will try to search on other forums, however, I await a response from you that you know more

Sorry, I did not understand your request. I am not able to help with the path on the Mac, and I think we need that to get the plugin to work.

In the meantime, you could try what @jeroen suggested: start TeXmacs from the terminal and see if Maxima works in that case.

ok thanks, I will wait for suggestions from @mgubi or @vdhoeven if they had time. Thanks at all!!

I don’t know how, but now inserting in insert> session> scheme and inserting the string “(url-exists-in-path? “maxima”)” the result is true (#t) but despite this maxima does not appear in the sessions.
suggestions? @pireddag

Please try now again “Tools->Update->Plugins” from the menu (at least four or five times). If that does not work now too, we shall investigate more.

I try “Tools->Update->Plugins” (10 times) but nothing, Maxima there isn’t in session