Mogan Research v1.2.5 LTS Release Candidates available now

Your bug report is still important, because we will release v1.2.5.1 around 2024/03/31.

Need your help to make it perfect with less bugs

Just enjoyed the Spring Festival in China. As a result, Mogan v1.2.5 LTS will be a bug fix release with little new feature.

v1.2.5 LTS rc2 will be released with no code changes (will add more translations) and after rc2, v1.2.5 LTS will be released.

And within 1 month, v1.2.5.1 will be released for bug fixes or old computer support (eg. Windows 7) if I can get help from whom owns the old devices.

( For myself, I was a Windows XP user, and never used Windows 7. I’ve been using debian for about 10 years.)

Just added a package for debian bookworm (debian 12). If you are using debian bookworm, please help us to test it.

dpkg -i mogan-research-v1.2.5-debian12.deb: error processing package mogan-research (…) The packages libgit2-1.5 libqt6core6 libqt6gui6 libqt6printsupport6 libqt6svg6 libqt6widgets6 are not installed.
After installing these, everything is ok for the moment. THANKS !
I will continue testing.

1 Like

II can’t start the software under ubuntu 22.04.
Here is the copy of my terminal :

biz@biz-OptiPlex-9030-AIO:~$ MoganResearch
qt.qpa.plugin: Could not find the Qt platform plugin “xcb” in “”
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Thank you for any possible help.

xcb error seems to be a famous error related to Qt

I googled and found this stackoverflow question:

I think it should be the answer to your question.

A bit late but better than never!

This is the answer to you question:

sudo apt install qt6-qpa-plugins

I just installed a fresh new Ubuntu 22.04 desktop in virtualbox, and solved the problem.

And it will be solved in Mogan Research v1.2.5.2 by manually marking qt6-qpa-plugins as dependency of Mogan Research. Thanks for your bug report.